There is a delay in my headphones when I record.  I am using Audacity.  Is there a setting I have wrong or some way to fix this?  And if I'm at a loss in that regard completely, is there a way to shut off playback during recording so that at least there isn't noise coming from the headset when I put it down?  Thanks all!

Views: 6978

Reply to This

Replies to This Discussion

Cat - 

This sounds like the phenomenon known as "audio latency", and I'm guessing you're using Windows for your OS, which makes it worse; your audio interface can have a bit to do with it as well - some are better with latency than others, and many have software mixers that allow you to mute the sound that's being fed back to you. 

 

You didn't mention what hardware you're using so I can't offer specifics, but look around for info on how to reduce latency in it's documentation or on the manufacturer's support site - it's usually a matter of tweaking something called "buffer settings" for playback and recording for both the hardware and possibly in the backwaters of Audacity as well.

 

If you have Windows, check with your audio interface manufacturer to see if the hardware has an "ASIO driver", which helps a good bit in reducing latency. Macs don't need ASIO because they have a better-developed core audio/video engine, which is why gear geeks like me here in NYC use them pretty much exclusively in our daily work - much less hassle with settings and other "surprises" when you plug in a new piece of gear or load up a new software program.

 

All of this is pretty well explained and documented online, so get to Googlin', and good luck!

 

- SG

Will adjusting these settings help?  I am on Windows 7 using the Audacity Beta (newest) .  Thanks for your help... I'll look into those suggestions.  Off the top of your head, do you know if simply switching programs will help?  For example, I may be able to get Adobe Audition.

Cat -

 

You're off to a good start - bravo! 

 

However, since I've not mucked around with Audacity on Windows in a long time - particularly in Win7, even though I was an alpha tester of the OS a few years ago - I unfortunately can't tell you for sure what exactly to set, how to set it, and what to expect, so everything below is educated guesswork.

 

I'd first start with unchecking that Software Playthrough setting...it looks like that would solve your immediate problem of hearing echo. The downside is you might not be able to hear yourself in the headphones while you record (which is fine for some folks, but not me). If you're okay with that, then that's probably all you need to do.

 

If not, I'd try taking that Audio To Buffer number down a bit - right now, it's set to give you 1/10th of a second of delay. See if knocking it down to 20, 10, or even lower helps at all without causing audio to sound "chattery" or chopped up when you record or play back. Supposedly, most folks can't hear the difference below 20 ms, so see if you can work around that number and tweak slightly higher or lower if things get messy.

 

NOTE: The wild card here is that Latency Correction setting. Never seen or used it before, so no idea if it'll affect things for your situation. Might even help to set it to zero, but definitely refer to the Audacity help documentation or wiki if things get out of hand!

 

- SG

 

P.S: There may also be similar latency settings in the Playback preference panel too that may help (above Recording on the left column. The trick with latency is to try to set it as low as you can in without affecting things, and it's different from system to system. Again, experimentation is key - as is writing down or screengrabbing initial settings before you change anything!

 

That is not the solution for me, but thank you for taking the time to respond.

Cat, I don't know if you have figured this out already, but it sounds like you're going straight into the computer from your mic. Maybe you're using a USB mic. 2 things to try. in the sound properties of the input in windows 7, there is a tab for 'listen'. if you check that windows will loop the input back out instantly for you. another way, which is how I do it is to run my mic into a mixer that has headphones output in addition to the record out and mains out and all that other stuff. that's the best way for me.  hope that helps.

Thank you! I will try that tomorrow!

RSS

© 2017   Created by VU - Founder - Zurek.   Powered by

Badges  |  Report an Issue  |  Terms of Service